Usually the LayerSlider is running properly on any server, where the PrestaShop 1.5+ is working without any issue. It doesn't have any special requirement, so it should work on most of the servers.

PHP & Extensions

The minimum version number of PHP is 5.2.4+ or any higher version.
The PHP GD - Graphics Directory is also required. Usually it is enabled on the 99.9% of the servers.


The required version is 5.0.4+.


LayerSlider supports Prestashop 1.5.x, 1.6.x and 1.7.x versions. Please note, that is always recommended to have the latest version installed of PrestaShop system, as well as the used modules.

© WebshopWorks - Professional PrestaShop Addons